This can happen. We cannot anticipate all interactions between software version and platforms.

We have an ever-expanding set of hardware and OS platforms on which Mbed TLS is automatically built. Please open a discussion or file a ticket on Github, or contact us directly.

Please provide us with as much information as possible on:

  • The compilation error you encounter.
  • The compiler (type and version) you use.
  • The chipset of your system.
  • The operating system you use.

Did this help?