Hello. I have the following suggestion: config.h must be renamed to something like polarssl_config.h or similar. If I maintain 2+ projects using PolarSSL and the source code of PolarSSL is shared between all projects, it may be necessary to have different config.h for each project using specific features. For that reason config.h must be moved to project directories or project-specific "config"/"include" directory. But with current file name this is complex task because of possible duplicates with other "config.h" files. For example, configuration of FreeRTOS is in FreeRTOSConfig.h.
I understand your situation.We might change this in the future.
In the meantime: Our 'quickfix' for similar situations is to replace the entire standard polarssl/config.h in your 'central library' with just the following content:
And then put polarssl_config.h in the place you want. If you put the include dirs in the right order, this can potentially solve your issue?